wordpress3.4升级的问题

wordpress是咱们最常用的程序。当然,其臃肿的程序也为人诟病。当然其安全性和开放性让他成为了博客程序的大头.当然wordpress最近发布了3.4版本,很多朋友都升级了。也包括一个wordpress群里的朋友。阿福私下以为那个更应该称之为生活群,一群wordpress爱好者的生活群~

升级时候会出现如下错误,当然群里的朋友出现的语句和这个不一样。这个是阿福从网上找来的。

Fatal error: Call to undefined method wpdb_2::delete() in

/home/*/public_html/wp-includes/option.php on line 370

反正不管神马样的,错误总会出现在370行。出现错误的原因是由于有数据库缓存插件引起的如DB-Cache这类的。

解决办法是删除该插件。

当然这类解决办法是治标不治本的。

在wordpress新版本中,修改了很多的东西,内核啊神马的。所以,劝朋友不要急着升级。

从谷歌上谷歌的问题,大多数是存在着数据库类缓存插件引起的。各位朋友在升级以前一定要备份数据库,关闭所有插件。以便升级成功。当然主题也可以更换为默认主题为好。

 

作者: 阿福

购买时被坑爹的枪手坑了。只知道介绍如何如何的好,不知道介绍其坏处。因此,写此博客,望能给各大网友帮助。

《wordpress3.4升级的问题》有6个想法

发表评论

电子邮件地址不会被公开。 必填项已用*标注